Explorer++ Process Not Shutting Down, Much Memory Used

Ask any support questions here
Post Reply
dave9
Posts: 2
Joined: Sun Aug 09, 2020 3:42 am

Explorer++ Process Not Shutting Down, Much Memory Used

Post by dave9 »

Win7 x64 SP1 system
Explorer++ 1.4.0.1637

I've used Explorer++ for a couple days now, and after closing all Explorer++ windows, I have an instance of the process still running (seen in Windows Task Manager) taking up almost 1GB memory.

Is this a program bug or how do I troubleshoot this? It is a fairly worn in (years old, slowly modified over time, not stock) Win7 install, that I'm not going to install from scratch so let's just take that off the table now. That 1GB process shuts down using Task Manager and upon loading Explorer++ again, seems to have normal (?) memory usage of about 11MB per process and I didn't notice it misbehaving in any way during use, but clearly I don't want a phantom 1GB process lingering around all the time.

Also while I'm posting, how do you make Explorer++ 1.4, open a volume with a direct shortcut to its root, for example if I make a shortcut to C:\ and click it, Explorer++ opens My Computer showing all drives, instead of opening C:\ ? I mean after having set it to Default File Manager > "Replace Explorer for all folders".

Edit: I see now that when it opens My Computer it is opening what is set under Options > General > General settings as "Default new tab folder". Whatever I set the default new tab folder to, is what opens if I click a shortcut to C:\ (or D:\, or E:\, and so on). How can I just open Explorer++ at the root of that volume?

dave9
Posts: 2
Joined: Sun Aug 09, 2020 3:42 am

Re: Explorer++ Process Not Shutting Down, Much Memory Used

Post by dave9 »

Kept seeing memory utilization creeping up on v 1.4, just navigating around then showing a folder with a few dozen files, over 100MB memory used.

Decided to revert back to 1.3.5.531 x64, which does open volume roots from shortcuts, and hopefully memory use will stay in check. It's really acceptable except the main toolbar icons are too small for modern high res. monitors... and I am using "large toolbar icons", which look small and I'd rather some near double the size.

I propose that if the bugs in v1.4 can't be resolved to take it past beta w/issues, that v1.3.5 at least has the icons doubled in size. There might be some fancy things in v1.4 that I don't appreciate, but when talking about the Explorer bundled with Win7 or newer in windows, more than anything I just want the features back that Explorer had in WinXP, that behavior and feature set... only reason I was compelled to use Explorer++ was the maddening auto-resize of columns in Win7, which makes it barely even usable if you deal with longer file names sometimes, but not in every folder. That destroys the efficiency of having a modern high resolution screen where you could otherwise tile windows and use them all without resizing columns every time you open a folder. Ugh!

... okay having let v 1.3.5 sit a while and doing other routine things similar to when using v1.4, the memory utilization isn't getting out of control yet, is still around a dozen MB per window/process.

Post Reply