Turn off light blue highlight following mouse everywhere

Share any ideas you have on improving Explorer++
Post Reply
EM1336
Posts: 1
Joined: Mon May 31, 2021 11:39 am

Turn off light blue highlight following mouse everywhere

Post by EM1336 »

Hello,

Is there any way to turn off the annoying light blue highlighting that follows the mouse when you hover or glide across files and folders? I find this distracting, similar to mouse trails or tooltips, and prefer a more minimalist interface like in macOS or Linux, or in the days before Vista. You can turn this "feature" off in Xplorer2, but I haven't been able to figure out how to turn it off in Explorer++ or Windows Explorer.

I'm using Explorer++ version 1.4.0.1838 dev (64-bit build) on Windows 10 Pro and, other than this one unsettling demon, everything else works beautifully. I had several other complaints (such as folders not auto-refreshing, newly-created folders not becoming the focus for rename, and general sluggishness) that were instantly solved when I upgraded from an old version to the latest version. The speed of the newest version in displaying the files and folders when you double-click on a folder is drastically improved from the version I had been using, where there seemed to be a 500 millisecond delay before anything would open and some folders would inexplicably take up to 2 seconds to open. I was almost ready to call it quits and learn to tolerate Windows Explorer when I had a hunch that I should click on "Help - Check for Updates".

Janus
Posts: 45
Joined: Fri Aug 05, 2016 9:03 am

Re: Turn off light blue highlight following mouse everywhere

Post by Janus »

The source of this evil is in

HWND ShellTreeView::CreateTreeView(HWND parent)

\explorer++\shelltreeview\shelltreeview.cpp:106

// WS_CHILD | WS_VISIBLE | TVS_SHOWSELALWAYS | TVS_HASBUTTONS | TVS_EDITLABELS | TVS_HASLINES | TVS_TRACKSELECT);

and I use

WS_CHILD | WS_VISIBLE | TVS_SHOWSELALWAYS | TVS_HASBUTTONS | TVS_EDITLABELS | TVS_HASLINES);

In my personal fork.
Just one of several things I removed or modified.

I have no idea who ever thought this was a good idea, but I find it infuriating.
Either the original idea for this in any gui, or for this program.

At the very least there should be a setting to turn this inanity off.
If I knew how, I would offer code to dis/enable it.
Still not good with gui programming, I work at bare metal and assembly level normally.
Finding the 'Why does the widget maker glitch only during a new moon on wednesday nights' since the upgrade kind of stuff.
I find gui programming FAR more complex.
To many layers, WAY to many random interactions.

Good luck with it.


Janus.

Post Reply