Current dev builds will not "run as another user"

Found a bug or something that needs fixing?
Post Reply
PGomersall
Posts: 4
Joined: Thu Jun 10, 2021 9:50 am

Current dev builds will not "run as another user"

Post by PGomersall »

The most current dev build will not "run as another user". This is either via using shift right-click then specifying the username\password or alternatively running say command prompt as that user and trying to execute the app. Using the version 1.3.5 works. In both tests using 64bit.
Here is output from command prompt, with crash details for 1.4.01838 and then 1.3.5 executing correctly with no errors.

D:\Explorer++>"Explorer++.exe"

D:\Explorer++>Could not convert: --application-crashed = 15772,15932,0x0,000,007,F99,17B,360,93E5AAF3-4557-4D2E-9825-FD99B5E3510E
Run with --help for more information.

D:\Explorer++>cd ..

D:\>cd Downloads

D:\Downloads>cd "explorer++_1.3.5_x64"

D:\Downloads\explorer++_1.3.5_x64>"Explorer++.exe"

D:\Downloads\explorer++_1.3.5_x64>

Note some previous version of 1.4.x was working though. I do not know when the bug was introduced.
Pete

PGomersall
Posts: 4
Joined: Thu Jun 10, 2021 9:50 am

Re: Current dev builds will not "run as another user"

Post by PGomersall »

The build 1788 will run as another user now.

PGomersall
Posts: 4
Joined: Thu Jun 10, 2021 9:50 am

Re: Current dev builds will not "run as another user"

Post by PGomersall »

After a bit more testing it seems a little more complicated. So, the newer builds will run as another user if you are logged on locally. However, if you are logged on via RDP they will not launch as another user. The 1.4.0 Beta 2 1748 works in both a local logon and via RDP.

Post Reply